From owner-ports-jp@jp.freebsd.org  Sun Aug  8 14:38:54 1999
Received: (from daemon@localhost)
	by castle.jp.freebsd.org (8.9.3+3.2W/8.7.3) id OAA52001;
	Sun, 8 Aug 1999 14:38:54 +0900 (JST)
	(envelope-from owner-ports-jp@jp.FreeBSD.org)
Received: from rr.iij4u.or.jp (h203.p060.iij4u.or.jp [210.130.60.203])
	by castle.jp.freebsd.org (8.9.3+3.2W/8.7.3) with SMTP id OAA51960
	for <ports-jp@jp.freebsd.org>; Sun, 8 Aug 1999 14:38:51 +0900 (JST)
	(envelope-from sada@rr.iij4u.or.jp)
Received: (qmail 50388 invoked by uid 1000); 8 Aug 1999 14:38:50 +0900
Date: 8 Aug 1999 14:38:50 +0900
Message-ID: <19990808053850.50387.sada@rr.iij4u.or.jp>
To: ports-jp@jp.freebsd.org, shige@FreeBSD.org
In-Reply-To: Your message of "Fri, 6 Aug 1999 23:45:19 JST".
	<199908061447.XAA00469@mta1.odn.ne.jp>
From: sada@rr.IIJ4U.OR.JP (SADA Kenji)
Mime-Version: 1.0
Content-Type: text/plain; charset=US-ASCII
X-Mailer: mnews [version 1.21] 1997-12/23(Tue)
Reply-To: ports-jp@jp.freebsd.org
Precedence: list
X-Distribute: distribute version 2.1 (Alpha) patchlevel 24e+990727
X-Sequence: ports-jp 7115
Subject: [ports-jp 7115] Re: semi for xemacs-mule (slave)
Errors-To: owner-ports-jp@jp.freebsd.org
Sender: owner-ports-jp@jp.freebsd.org
X-Originator: sada@rr.IIJ4U.OR.JP

# This is a shell archive.  Save it in a file, remove anything before
# this line, and then unpack it by entering "sh file".  Note, it may
# create directories; files and directories will be owned by you and
# have default permissions.
#
# This archive contains:
#
#	semi-xemacs-mule
#	semi-xemacs-mule/Makefile
#	semi-xemacs-mule/pkg
#	semi-xemacs-mule/pkg/COMMENT
#	semi-xemacs-mule/pkg/DESCR
#	semi-xemacs-mule/pkg/PLIST
#
echo c - semi-xemacs-mule
mkdir -p semi-xemacs-mule > /dev/null 2>&1
echo x - semi-xemacs-mule/Makefile
sed 's/^X//' >semi-xemacs-mule/Makefile << 'END-of-semi-xemacs-mule/Makefile'
X# New ports collection makefile for:	semi for mule
X# Version required:	1.8.6
X# Date created:		9 May 1999
X# Whom:			Shigeyuki FUKUSHIMA <shige@FreeBSD.ORG>
X#
X# $Id: Makefile,v 1.2 1999/05/21 13:30:51 shige Exp $
X#
X
XMASTER_SITES=	ftp://ftp.jaist.ac.jp/pub/GNU/elisp/semi/semi-1.13-for-flim-1.12/
X
XMAINTAINER=	shige@FreeBSD.ORG
X
X# This is a slave port.
XPORTCLASS=	slave
X
XMASTERDIR=	${.CURDIR}/../../editors/semi-emacs
X
XMAKE_FLAGS+=	LISPDIR=${PREFIX}/${EMACS_LIBDIR}/site-lisp \
X		VERSION_SPECIFIC_LISPDIR=${PREFIX}/${EMACS_LIBDIR}/site-lisp/emu
X
XFLIM_VER=	1.12.7
XSEMI_VER=	1.13.3
X
X# emacs port setup
XEMACS_NAME=	xemacs
XEMACS_PORT=	xemacs-mule
XEMACS_VER=	20.4
XEMACS_LIBDIR=		lib/${EMACS_NAME}-${EMACS_VER}
XEMACS_LIBDIR_WITH_VER=	lib/${EMACS_NAME}-${EMACS_VER}
X
XHAVE_COMMON_PORT=	YES
X#REQUIRE_SETUPEL=	YES
X
X# use pkg/* files in ${.CURDIR}
XPKGDIR=		${.CURDIR}/pkg
X
X.include <${MASTERDIR}/Makefile>
END-of-semi-xemacs-mule/Makefile
echo c - semi-xemacs-mule/pkg
mkdir -p semi-xemacs-mule/pkg > /dev/null 2>&1
echo x - semi-xemacs-mule/pkg/COMMENT
sed 's/^X//' >semi-xemacs-mule/pkg/COMMENT << 'END-of-semi-xemacs-mule/pkg/COMMENT'
XSEMI, Library of MIME feature for GNU Emacs for mule
END-of-semi-xemacs-mule/pkg/COMMENT
echo x - semi-xemacs-mule/pkg/DESCR
sed 's/^X//' >semi-xemacs-mule/pkg/DESCR << 'END-of-semi-xemacs-mule/pkg/DESCR'
XSEMI, Library of MIME feature for GNU Emacs for mule.
X
X  SEMI is a library to provide MIME feature for GNU Emacs.  MIME is a
X  proposed internet standard for including content and headers other
X  than (ASCII) plain text in messages.
X
X  SEMI has the following features:
X	- MIME message viewer   (mime-view-mode) (RFC 2045 .. 2049)
X	- MIME message composer (mime-edit-mode) (RFC 2045 .. 2049)
X
X  MIME message viewer and composer also support following features:
X	- filename handling by Content-Disposition field (RFC 1806)
X	- PGP/MIME security Multiparts (RFC 2015)
X	- application/pgp (draft-kazu-pgp-mime-00.txt; obsolete)
X	- text/richtext (RFC 1521; obsolete; preview only)
X	- text/enriched (RFC 1896)
X	- External method configuration by mailcap (RFC 1524)
X
X  Notice that this package does not contain MIME extender for any
X  MUAs.  They are released as separated packages.
X
X  SEMI is installed the following directory tree:
X	${PREFIX}/share/emacs/site-lisp/semi/	--- SEMI
X
X
XTo use flim, put the following setup into your ~/.emacs:
X
X	(require 'apel-setupel)
X	(require 'flim-setupel)
X	(require 'semi-setupel)
X
X--- Porting by shige <shige@FreeBSD.ORG>
END-of-semi-xemacs-mule/pkg/DESCR
echo x - semi-xemacs-mule/pkg/PLIST
sed 's/^X//' >semi-xemacs-mule/pkg/PLIST << 'END-of-semi-xemacs-mule/pkg/PLIST'
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-setup.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-setup.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/signature.el
X%%EMACS_LIBDIR%%/site-lisp/semi/signature.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/semi-def.el
X%%EMACS_LIBDIR%%/site-lisp/semi/semi-def.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-image.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-image.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-view.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-view.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-play.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-play.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-partial.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-partial.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-edit.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-edit.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/semi-setup.el
X%%EMACS_LIBDIR%%/site-lisp/semi/semi-setup.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mail-mime-setup.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mail-mime-setup.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-mc.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-mc.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-pgp.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-pgp.elc
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-bbdb.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-w3.el
X%%EMACS_LIBDIR%%/site-lisp/semi/mime-w3.elc
X@comment %%EMACS_LIBDIR%%/site-lisp/%%SEMI_SETUPEL%%
X@dirrm %%EMACS_LIBDIR%%/site-lisp/semi
X%%SEMIDOCDIR%%/ChangeLog
X%%SEMIDOCDIR%%/NEWS
X%%SEMIDOCDIR%%/README.en
X%%SEMIDOCDIR%%/TODO
X%%SEMIDOCDIR%%/VERSION
X@dirrm %%SEMIDOCDIR%%
X@unexec install-info --delete %D/info/mime-ui-en.info %D/info/dir
X@unexec install-info --delete %D/info/mime-ui-ja.info %D/info/dir
Xinfo/mime-ui-en.info
Xinfo/mime-ui-ja.info
X@exec install-info %D/info/mime-ui-en.info %D/info/dir
X@exec install-info %D/info/mime-ui-ja.info %D/info/dir
END-of-semi-xemacs-mule/pkg/PLIST
exit
